{"__v":4,"_id":"5530ab364c0c6d0d00bae463","category":{"__v":5,"_id":"54890902f291f61400c02d3e","project":"543b9b0065bf840e00b473d5","version":"543b9b0065bf840e00b473d8","pages":["54890948f291f61400c02d40","54895ef66a600c0b0051ae23","54895f836a600c0b0051ae25","5530ab364c0c6d0d00bae463","55d300c7486de50d00327221"],"reference":false,"createdAt":"2014-12-11T03:01:22.975Z","from_sync":false,"order":8,"slug":"troubleshooting","title":"Troubleshooting"},"project":"543b9b0065bf840e00b473d5","user":"543b9aa865bf840e00b473d1","version":{"__v":11,"_id":"543b9b0065bf840e00b473d8","project":"543b9b0065bf840e00b473d5","createdAt":"2014-10-13T09:27:28.467Z","releaseDate":"2014-10-13T09:27:28.467Z","categories":["543b9b0065bf840e00b473d9","543b9ef065bf840e00b473e0","54890012f291f61400c02d36","54890902f291f61400c02d3e","54890c43f291f61400c02d44","54890d71c178b40b00aa3086","5508125c0c4d8c19008a5f83","55094050961f17170070abbd","550945111c38c50d006118ad","550a4c2e42fff40d00ae6049","55221c074801a40d00a77610"],"is_hidden":false,"is_beta":false,"is_stable":false,"codename":"","version_clean":"1.0.0","version":"1.0"},"updates":[],"createdAt":"2015-04-17T06:41:58.676Z","link_external":false,"link_url":"","githubsync":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"auth":"required","params":[],"url":""},"order":3,"body":"With the release of Unity 5, we've decided to improve the scripting for compatibility, but at the cost of losing compatibility for Unity 4.6 and below. In an effort to embrace upcoming changes from Unity, we've gone ahead with the improvement for the Complete Kit.\n[block:callout]\n{\n  \"type\": \"info\",\n  \"title\": \"Applies only to the Complete Kit\",\n  \"body\": \"If you have the Pro or Starter Kit, this error should not apply to you. If you get a similar error, please contact us so we can investigate.\"\n}\n[/block]\n\n[block:code]\n{\n  \"codes\": [\n    {\n      \"code\": \" \\\"Assets / Scripts / Save / SaveLoadBattle.cs (539,41): error CS0246:.\\nThe type or namespace name` Helios' could not be found Are you missing\\na using directive or an assembly reference? \\\"\",\n      \"language\": \"cplusplus\"\n    }\n  ]\n}\n[/block]\nThe new version of the Complete Kit is compatible with Unity 5, but not earlier versions of Unity. We've released a new build in the download center for Unity 5 compatibility to fix the issue with Unity 5 and the Helios PvP script.\n\nOtherwise, if you cannot upgrade to Unity 5, reverting to previous versions of NGUI or 2D Toolkit should remove the error. If you continue to have problems even after reverting to an earlier version of NGUI/2DTK, please contact us and ask for the Helios Unity 4.6 compatible backup.\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Unity 4.6.4 Error Message\"\n}\n[/block]\nIf you use Unity 4.6.4 or below, you may receive this message when installing older versions of the Complete Kit. Upgrade your Unity version to version 5, and this message should not show.\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://www.filepicker.io/api/file/GCGniKDRQpCorMR4DLls\",\n        \"Screen Shot 2015-04-16 at 6.15.36 PM.png\",\n        \"529\",\n        \"347\",\n        \"#893709\",\n        \"\"\n      ],\n      \"caption\": \"Upgrading Project Unity 4.6.4 error\"\n    }\n  ]\n}\n[/block]","excerpt":"","slug":"helios-bug-unity-464","type":"basic","title":"Helios Bug (Unity <4.6.4)"}

Helios Bug (Unity <4.6.4)


With the release of Unity 5, we've decided to improve the scripting for compatibility, but at the cost of losing compatibility for Unity 4.6 and below. In an effort to embrace upcoming changes from Unity, we've gone ahead with the improvement for the Complete Kit. [block:callout] { "type": "info", "title": "Applies only to the Complete Kit", "body": "If you have the Pro or Starter Kit, this error should not apply to you. If you get a similar error, please contact us so we can investigate." } [/block] [block:code] { "codes": [ { "code": " \"Assets / Scripts / Save / SaveLoadBattle.cs (539,41): error CS0246:.\nThe type or namespace name` Helios' could not be found Are you missing\na using directive or an assembly reference? \"", "language": "cplusplus" } ] } [/block] The new version of the Complete Kit is compatible with Unity 5, but not earlier versions of Unity. We've released a new build in the download center for Unity 5 compatibility to fix the issue with Unity 5 and the Helios PvP script. Otherwise, if you cannot upgrade to Unity 5, reverting to previous versions of NGUI or 2D Toolkit should remove the error. If you continue to have problems even after reverting to an earlier version of NGUI/2DTK, please contact us and ask for the Helios Unity 4.6 compatible backup. [block:api-header] { "type": "basic", "title": "Unity 4.6.4 Error Message" } [/block] If you use Unity 4.6.4 or below, you may receive this message when installing older versions of the Complete Kit. Upgrade your Unity version to version 5, and this message should not show. [block:image] { "images": [ { "image": [ "https://www.filepicker.io/api/file/GCGniKDRQpCorMR4DLls", "Screen Shot 2015-04-16 at 6.15.36 PM.png", "529", "347", "#893709", "" ], "caption": "Upgrading Project Unity 4.6.4 error" } ] } [/block]